콘텐츠로 건너뛰기

COMPUTING

node.js max-http-header-size

Node.js 응용프로그램에서 HTTP 요청시 HTTP ERROR 4311 응답이 확인되면 서버의 구성을 변경해서 요청 헤더 크기의 조정이 필요할 수 있습니다. 아래 실행 옵션 또는 환경변수를 추가하기 전에 현재 사용중인 node.js 버젼을 먼저 확인하십시오. v13.13.0 이전 버젼을 사용중이면, v13.13.0 이후 버젼으로 변경을 검토하시는게 좋을 것으로 생각됩니다. v13.13.0… 더 보기 »node.js max-http-header-size

Configure end of line when using git for multi-platform development teams

개발팀의 장비가 여러 플랫폼으로 구성된 경우 GIT 구성에 따라 변경사항이 없음에도 많은 파일이 스테이징 대상으로 출력됩니다. 보통 줄의 끝 (EOL; End of line)을 처리하는 방법이 OS 마다 달라서 발생합니다. 많이 사용되는 OS에서 줄의 끝을 표현하는 방법은 아래와 같습니다. Windows 는 CRLF (\r\n Carage return, Line… 더 보기 »Configure end of line when using git for multi-platform development teams

Many to many relationship on EntityFrameworkCore 6

EntityFrameworkCore 6 에서 다대다 관계 구성이 향상되었다고 해서 관련 내용을 확인했습니다. 데이터 입출력시 중간 테이블을 거치지 않고 구현이 가능합니다. GitHub: bbonkr/sample.ef.mtom 저장소에서 코드를 확인할 수 있습니다. 예제 테이블 Student Name Nullable Constaint Id NN PK Name NN Cource Name Nullable Constaint Id NN PK Title… 더 보기 »Many to many relationship on EntityFrameworkCore 6

Change the web application target framework from .NET 5 to .NET 6

.NET 5 웹 응용프로그램을 .NET 6 웹 응용프로그램으로 변환하고, 관련 내용을 요약해서 작성했습니다. Target Project GitHub: bbonkr/bing-wallpaper 웹 응용프로그램의 대상 프레임워크를 .NET 5 에서 .NET 6(으)로 변경합니다. Requirements 대상 프레임워크를 .NET 6(으)로 변경 Program.cs 파일의 내용을 최상위 문 (Top level statements) 으로 재작성 파일 범위… 더 보기 »Change the web application target framework from .NET 5 to .NET 6

NPM @bbon/react-calendar package

타입스크립트로 작성된 리액트 달력 컴포넌트입니다. peer dependencies react NPM GitHub react-dom NPM GitHub dayjs NPM GitHub 설치 $ npm install –save @bbon/react-calendar 사용 import React, { useCallback } from ‘react’; import { Calendar } from ‘@bbon/react-calendar’; import ‘@bbon/react-calendar/dist/calendar.css’; const MyComponent = () => { const… 더 보기 »NPM @bbon/react-calendar package

다국어 지원 next.js 웹 응용프로그램

next.js 웹 응용프로그램이 다국어를 지원하기 위해 next-i18next 를 사용하는 예제에 대한 설명입니다. baseURL 하위 경로를 사용해서 언어별 라우트가 구현됩니다. http://myapp.com <- 기본 언어 http://myapp.com/en <- 영어 http://myapp.com/ru <- 러시아어 의존 패키지 관련 의존 패키지는 아래와 같습니다. next 12.0.4 next-i18next 9.1.0 react 17.0.2 react-dom 17.0.2 $… 더 보기 »다국어 지원 next.js 웹 응용프로그램